As you might know, Google Chrome is no longer supported on older enterprise Linux distributions such as RHEL6 and clones. The system requirements page only shows recent versions of Ubuntu, OpenSUSE, Debian and Fedora under the supported OS list. Luckily I found this very useful guide to install it.