Most Linux distributions don’t always provide latest versions for all packages within the official repository (e.g. the current VLC version in Fedora 13 is 1.0.6, theĀ  one from the Rawhide repo — which includes packages for the next Fedora release — is 1.1.0, but the latest release as of today is 1.1.2).

So, what do you do to run the latest version?

Compile it yourself, of course.

How?

  1. Download the latest version (1.1.2)
  2. Unpack it and cd to the newly created folder (vlc-1.1.2). Here you will find the README file and the installation instructions (same as here)
  3. Compile it. I recommend creating a new path (e.g. /opt/vlc) to use it as the installation PREFIX
  • ./configure –prefix=/opt/vlc
  • make
  • su -c "make install"

Issues?

  • Running ./configure can fail if there are missing dependencies. Install them, then try again. I had to install the following packages before running configure successfully:
yum install lua-devel libmad-devel ffmpeg-devel a52dec-devel libxcb-devel libX11-devel mesa-libGLU-devel
  • make sure you have pulseaudio-libs-devel and alsa-lib-devel installed to compile vlc with pulseaudio/alsa support

After a successful installation you can start vlc with /opt/vlc/bin/vlc. Enjoy.