Install Electrum-VTC on Centos 7

Author: | Posted in cryptocurrency No comments

I did this on CentOS 7.4 but it should work the same for any future minor OS release. By default Electrum-VTC 2.9.3 (an official wallet for the Vertcoin cryptocurrency) does not run on CentOS/RHEL 7 instances as it is missing some required libraries and symlinks. After extracting the tar.gz from the official download site and attempting to run the executable, this type of error may occur:

$ ./electrum-vtc
Error: No module named urllib3. Try 'sudo pip install '

I’ve identified several packages that need to be installed as dependencies and this is the way to install them correctly:

yum install
yum install PyQt4 python2-pip python-devel gcc
pip install --ignore-installed --install-option="--prefix=/usr/local" --proxy=$PROXY:PORT urllib3 chardet certifi idna lyra2re_hash lyra2re_hash vtc_scrypt
cd ~/Downloads/Electrum-VTC-
for i in urllib3 chardet certifi idna; do ln -s /usr/local/lib/python2.7/site-packages/$i .; done
for j in lyra2re_hash lyra2re_hash vtc_scrypt; do ln -s /usr/local/lib64/python2.7/site-packages/$ .; done



  • Replace the path where Electrum-VTC was extracted
  • The proxy setting is optional in case your are behind a proxy.
  • Some packages in the ‘pip install’ command may be already available on your system, but the symlinks still need to be created manually.

Hope this helps!

Add Your Comment